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FORWARD 
 
This Battery Life Estimator Manual was prepared for the United States Department of 
Energy (DOE), Office of Energy Efficiency and Renewable Energy (EERE), Vehicle 
Technologies Program.  It is intended to assist developers in successfully estimating 
battery life capability for electric, hybrid-electric, or plug-in hybrid electric vehicle 
applications based on accelerated performance and life characterization using the 
procedures that have been defined in the previously published DOE testing manuals.  The 
original publication of this Battery Life Estimator Manual included life estimation 
techniques based on a default linearizable model.  In Revision 1, a default nonlinear 
model is also included as well as a rate-based degradation model that can be useful in 
assessing memory effects during aging under non-isothermal conditions.  A software 
package (“BatteryLife.exe”) has also been developed based on the methodologies and 
default models that are described in this manual; software licenses can be obtained from 
Argonne National Laboratory. 
 
The DOE-United States Advanced Battery Consortium, Electrochemical Energy Storage 
Technical Advisory Committee supported the development of this manual.  Technical 
team point of contacts responsible for its development and revision are Jon P. 
Christophersen of Idaho National Laboratory (INL), Ira Bloom of Argonne National 
Laboratory (ANL), Edward Thomas of Sandia National Laboratories (SNL), and Vincent 
Battaglia of Lawrence Berkeley National Laboratory (LBNL). 
 
The development of this manual was funded by the United States Department of Energy, 
Office of Energy Efficiency and Renewable Energy, Vehicle Technologies Program.  
Technical direction from DOE was provided by David Howell, Energy Storage R&D 
Manager and Hybrid Electric Systems Team Leader, and Brian Cunningham, Energy 
Storage Testing, Design, and Analysis Program Manager. 
 
Comments and questions regarding this manual should be directed to Jon P. 
Christophersen at the Idaho National Laboratory (jon.christophersen@inl.gov).  
Comments and questions regarding the Battery Life Estimation software tool should be 
directed to Ira Bloom at the Argonne National Laboratory (ira.bloom@anl.gov). 
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GLOSSARY OF TERMS 

Beginning of Life (BOL) – The point in time at which life testing begins.  A distinction is 
made in this manual between the performance of a battery at this point and its 
initial performance, because some degradation may take place before the start of 
life testing.  Analysis of the effects of life testing is based on changes from the 
BOL performance. 

Calendar Life – The time required to reach end of life at the reference temperature at 
open-circuit (corresponding to key-off/standby conditions in the vehicle). 

Cycle Life – The number of consecutive cycles consisting of a charge neutral 
combination of discharge and charge pulses centered on a given state-of-charge 
for Hybrid Electric Vehicles (HEVs) or between given voltage limits for Plug-in 
Electric Vehicles and Electric Vehicles (PHEVs and EVs) required to reach end 
of life at the reference temperature. 

Degradation Model – An empirical- or chemistry/physics-based model that describes the 
expected degradation of a battery experiencing typical stress conditions. 

Depth of Discharge (DOD) – The percentage of a device’s rated capacity removed by 
discharge relative to a fully charged condition, normally referenced to a constant 
current discharge at the C1/1 rate.  The capacity to be used is established (fixed) at 
the beginning of testing, %. 

End of Life (EOL) – A condition reached when the device under test is no longer capable 
of meeting the applicable USABC goals.  This is normally determined from RPT 
results, and it may not coincide exactly with the ability to perform the life test 
profile (especially if cycling is done at elevated temperatures.)  The number of 
test profiles executed at end of test is not necessarily equal to the cycle life per the 
USABC goals. 

End of Test (EOT) – The point in time where life testing is halted, either because criteria 
specified in the test plan are reached, or because it is not possible to continue 
testing. 

Error Model – A model that accounts for the difference between the measured and 
expected performance.  The error model combines the effects of both 
measurement error and manufacturing variability. 

Lack of Fit Statistic – A statistic that measures the implausibility of the observed data 
given the assumed degradation and error models.  The statistic compares the 
differences between the observed average response (e.g., relative resistance) 
within each treatment/group and the response for that group that is predicted by 
the degradation model.  The differences are normalized by the within-group 
standard deviation predicted by the error model.  The sum of the differences 



 xiv

forms the lack of fit statistic.  Abnormally large values of the statistic indicate 
lack of fit. 

Memoryless Degradation – A process wherein the degradation rate of a cell depends only 
on its present state and present stress levels. 

Reference Performance Test (RPT) – A periodic assessment of battery degradation during 
life testing.  A reference performance test will typically yield capacity fade, power 
fade, and impedance rise as a function of test time. 

State of Charge (SOC) – The available capacity in a battery expressed as a percentage of 
actual capacity.  This is normally referenced to a constant current discharge at the 
C1/1 rate.  For this manual, it may also be determined by a voltage obtained via a 
relationship of capacity to voltage established at beginning of life.  SOC = (100 – 
DOD) if the rated capacity is equal to the actual capacity, %. 

Stress Factors – The parameters that are used to accelerate aging of a battery technology, 
such as temperature, state-of-charge, throughput, and pulse power.  These are the 
explanatory variables in the degradation model. 

 



 xv

ACRONYMS 

ANL Argonne National Laboratory 

BLE Battery Life Estimator 

BOL beginning of life 

CDF cumulative distribution function 

CSV comma separated value 

DOD depth of discharge 

DOE Department of Energy 

EERE Energy Efficiency and Renewable Energy 

EOL end of life 

EOT end of test 

EV electric vehicle 

HEV hybrid electric vehicle 

HPPC hybrid pulse power characterization 

INL Idaho National Laboratory 

LBNL Lawrence Berkeley National Laboratory 

LCL lower confidence limit 

LOF lack of fit 

MAV median absolute value 

PHEV plug-in hybrid electric vehicle 

RPT reference performance test 

SEI solid electrolyte interphase 

SNL Sandia National Laboratories 

SOC state of charge 

SS sum of squares 

TLVT Technology Life Verification Testing 

UCL upper confidence limit 

USABC United States Advanced Battery Consortium 
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Battery Calendar Life Estimator Manual 

 

1. INTRODUCTION 

1.1 Purpose and Applicability 

The purpose of this Battery Life Estimator (BLE) Manual is to assist developers in their 
efforts to determine the life capability of advanced battery technologies for automotive 
applications.  Testing requirements and procedures have been previously defined in 
various manuals (e.g., References 1 through 4) published under the United States 
Advanced Battery Consortium (USABC).  This manual describes a standardized method 
for determining the calendar life capability of battery technologies with a high degree of 
statistical confidence based on models and degradation data acquired from typical 
USABC performance testing. 

A software package (“BatteryLife.exe”) has also been developed to estimate calendar life 
capability based on the methodology described herein.  To acquire the software, users 
must first download and sign the license agreement at http://www.anl.gov/techtransfer/ 
Software_Shop/TLVT/TLVT.html.  USABC developers can license the software at no 
cost, but others will have to pay a nominal fee.  The degradation models presented in this 
manual have been included as default options for quick implementation to a set of data.  
However, the software can also accommodate other degradation models that are 
applicable to a particular chemistry. 
 
The offline battery life estimation methods provided in this manual and associated 
software tool are typically performed during Stage 1 or Stage 2 testing as defined in the 
Technology Life Verification Testing Manual (TLVT, Reference 5).  Stage 1 testing 
consists of short-term screening studies of a battery technology to assess its performance 
capability relative to the USABC targets.  Applied examples of battery life estimation 
based on Stage 1 testing for a set of experimental cells are provided in References 6 and 
7.  Stage 2 testing assumes a reasonably mature cell chemistry that is subjected to 
accelerated aging techniques to demonstrate its readiness for transition to production.  
Battery life estimation techniques could also be applied for Stage 3 testing, where 
complete battery systems are assessed for implementation and projected warranty costs, 
but other critical variables should be included within the models (e.g., cell balancing, 
thermal management, etc.).  Stage 4 is for online battery health assessment, which can 
use the models and offline life estimation results as a baseline to gauge performance 
capability. 

This manual specifically covers calendar-life estimations based on a default linearizable 
or nonlinear battery degradation model and associated error model.  However, the 
software tool also provides an option to estimate cycle-life capability with performance 
degradation as a function of cycle number.  The resulting life estimation will be based on 
the total number of cycles a battery is predicted to be able to complete at a given stress 
factor (i.e., temperature or state-of-charge). 
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1.2 Manual Organization 

This manual is organized into five main sections.  Section 2 describes the default 
statistical models implemented in the software tool (both linearizable and nonlinear 
forms) as well as the methods for estimating model parameters and cell life from 
experimental data.  This section also presents a methodology for assessing the uncertainty 
of the estimated cell life using Monte Carlo simulations.   Section 3 demonstrates the 
capabilities of both the linearizable and nonlinear models when applied to a set of 
experimental data.  Section 4 describes a rate-based modeling approach that could be 
applied when steady state conditions are not present and provides an example of how this 
model could be implemented using a set of experimental cells that were aged under non-
isothermal conditions.  Section 5 is a user’s guide for the software tool 
(“BatteryLife.exe”) and provides details on data formatting, menu navigation, and data 
processing.  Appendix A is an extended discussion of parameter estimation using robust 
regression techniques.   
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2. METHODOLOGY FOR ESTIMATING CALENDAR-LIFE 

This section describes a methodology for estimating the average calendar life capability 
of various cell technologies and assessing their readiness for transition to production.  
Consequently, the emphasis is placed on predicting the capability of typical (i.e., 
representative) cells to meet the USABC target of a 15-year calendar life.  A two-part 
model can be constructed from the experimental test data.  The first part is the 
degradation model that represents the average cell performance as a function of aging 
over a range of stress conditions.  The second part is the error model that represents the 
deviation of the cell behavior relative to the average performance.  The degradation 
model provides a basis for the estimation of average cell life and the error model provides 
a basis for assessing the accuracy of the degradation model. 

The degradation model can be empirical, chemistry/physics-based, or some combination 
of both (i.e., semi-empirical).  A wide variety of model forms are possible.  The specific 
form of the model will necessarily depend on the particular technology and set of stress 
factors.  For Stage 1 and Stage 2 testing, as defined in the TLVT Manual (Reference 5), 
there will generally be incomplete knowledge of the specific degradation mechanisms or 
the source of the deviations between average performance and actual measured 
performance.  Thus, relatively simple empirical or semi-empirical models with few 
parameters should be used for life estimation, though physics-based models could also be 
used if they are available.  Simple forms of a degradation model and error model that 
have been successfully implemented for a variety of technologies are illustrated herein.  
The methodology for estimating model parameters, assessing model accuracy, and 
estimating mean cell life with associated uncertainty are also described. 

 

2.1 Generalized Model 

The use of accelerated degradation testing to verify life capability requires the selection 
of performance measures that accurately reflect battery state of health (Reference 5).  An 
example performance measure is relative resistance (i.e., the cell resistance at time t 
divided by the resistance at beginning of life, t = 0).  The generalized model must relate 
the measured cell performance at any given time to a combination of the stress factors.  
For example, in the case of calendar-life experiments with a single stress factor of 
temperature, the acquired data can be represented generically by the model shown in 
Equation (1), where  tTYi ;  represents the measured performance (e.g., relative 

resistance) of the ith cell in the test matrix after being subjected to aging for time t at 
temperature T (Reference 6).  The average cell performance is represented by a 
degradation model,  tT ; , which may be in a linearizable form (Section 2.2) or a 
nonlinear form (Section 2.3).  The combined effects that are related to the unique 
behavior of the ith individual cell and measurement error are represented by an error 
model  tTi ; , which is described in Section 2.4. 

     tTtTtTY ii ;;;                  (1) 
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2.2 Linearizable Degradation Model 

In the example case of a single stress factor (temperature), a simple but useful form for a 
linearizable degradation model is given by Equation (2), where   and , , 10 represent 

the model parameters (Reference 6).  This is a semi-empirical model that combines the 
observed behavior from acquired test data with a chemistry/physical basis.  In the generic 
case, the physical basis of this model comes from an assumed Arrhenius behavior (i.e., 
exp(1/T)), which is a thermally activated process.  When the observed degradation has a 
square-root of time dependence (i.e.,  = 0.5), the model describes a diffusion controlled 
process that is governed by parabolic kinetics. 

   t
T

tT 






 

1
exp1; 10               (2) 

Note that   1; tT for t = 0 and then increases in value as the cell ages.  Various 
normalized responses, including relative resistance, are consistent with these conditions.  
If the natural response decreases to zero as a function of cell age,  tT ;  can be 
considered as a model for the inverse of the natural response.  Examples of a naturally 
decreasing response include relative power and relative capacity.  In such cases,  tT ;  
can be considered as a model for inverse relative power or inverse relative capacity. 

To estimate the parameters associated with this degradation model, it is useful to re-
express the model in a linear form with a log transformation as shown in Equation (3).  
Once the model has been linearized, robust regression can be used to estimate the model 
parameters using the methods described in Section 2.5. 

    t
T

tT log
1

1;log 10                (3) 

A generalized form of the linearizable degradation model is shown in Equation (4).  This 
model form assumes multiple stress factors, X1, X2,…Xn, as a function of test time.  As 
discussed in the TLVT Manual (Reference 5), these stress factors can include 
temperature, state-of-charge (SOC), throughput, and pulse power ratings.  The 
corresponding model parameters are 0 1 2,  ,  ,...,  and n     .  

   1 2 0 1 1 2 2, ,..., ; 1 exp ...n n nX X X t X X X t                      (4) 

 

2.3 Nonlinear Degradation Model 

Some battery performance data are not easily fit with a linearizable model.  A nonlinear 
degradation model is shown in Equation (5) using the example case of a single stress 
factor (temperature), where   and , , 10 represent the model parameters.  This model 

form is also semi-empirical and the physical basis comes from a logistic growth 



 5

perspective, where the change in the degradation parameter becomes limited by the lack 
of reactive materials.  Specific applications of this model can vary depending on the 
observed trends in the performance data.  The generalized form for this nonlinear model 
with additional stress factors is shown in Equation (6). 

  0 1

1
; 1 expT t t

T



            
              (5) 

   1 2 0 1 1 2 2, ,..., ; 1 exp ...n n nX X X t X X X t


                       (6) 

For this nonlinear form, model parameters are estimated with the Levenberg-Marquardt 
method (References 8 and 9).  The Levenberg-Marquardt method is an iterative algorithm 
that is used to find the minimum of a nonlinear function.    When used in the context of 
curve fitting, this method minimizes the least-squares errors between the data and the 
objective function, f, and can be expressed as shown in Equation (7), where J is the 
matrix of gradients of f with respect to each β, β is a parameter of f(x, β), λ is a dampening 
factor, δ is an incremental change in β, and y is the observation at x (Reference 9).  For 
this implementation, the Levenberg-Marquardt method uses the same robust regression 
techniques described in Section 2.5 to make it less sensitive to outliers and to estimate 
errors. 

     diag ( )y f      
T T TJ J J J J              (7) 

 

2.4 Error Model 

The error model accounts for the difference between the measured performance and 
expected performance.  The difference is a combination of effects due to measurement 
error as well as physical and chemical variations in cell manufacturing.  Two different 
approaches for determining the measurement error are discussed in this section.  One 
method estimates the error from the measured data, and the other method independently 
determines the error based on calibration and accuracy checks of the test equipment.  The 
software tool (“BatteryLife.exe”) provides both options to the user for life prediction. 

2.4.1 Estimated Error Model 

In the example case of a single stress factor (temperature), a useful form for the estimated 
error model (Reference 6) is given by Equation (8), where i  represents a random, cell-

specific, proportional effect with variance 2
 , and  ti  represents the effects of 

measurement error on  tTYi ; .   

      ttTtT iii   1;;               (8) 
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Using relative resistance as the performance measure, the expression for  tTYi ;  is as 

shown in Equation (9), where  tiRtrue ,  is the unknown (but true) value of the resistance 

of the ith cell at time t, and  ti  is the specific unknown error associated with that 

measurement. 

     
   00,

,
;

itrue

itrue
i iR

ttiR
tTY







                (9) 

The resulting error model due to measurement effects is shown in Equation (10).  

     
   

 
 0,

,

00,

,

iR

tiR

iR

ttiR
t

true

true

itrue

itrue
i 








             (10) 

It is assumed that the measurement errors are independent with a relative standard 
deviation of i.e.  0,iRtrue  ).  With this and other assumptions (Reference 6), the 

variance of  ti , given by 2
 , can be approximated by 22  . 

Assuming that the mean values of  ti  and i  are zero, then within a given group of 

cells that have experienced the same stresses and aging time, the mean and variance of 
 tTYi ;  can be expressed as shown in Equations (11) and (12).  Robust regression (see 

Section 2.5) is used to estimate the variance model parameters ( 2
  and 2

 ). 

    tTtTYMean i ;;               (11) 

         222 1;;;    tTtTVartTYVar ii           (12) 

Thus, this model of the variance within a treatment group and Reference Performance 
Test (RPT) (References 1-4), implies that the expected variability in cell performance 
increases as the expected level of degradation increases. 

2.4.2 Independent Assessment of Measurement Error 

Alternatively, the magnitude of measurement error can be estimated directly using the 
uncertainty methodology developed at the Idaho National Laboratory (References 10 and 
11).  First, the effect of measurement error can be minimized with test equipment 
calibration and verification.  Calibration can be performed using the manufacturer’s 
recommended procedures.  Verification consists of independent measurements of test 
channel voltage and current outputs at various levels within the channel full scale 
operating range.  The total equipment and channel error can then be determined by the 
measured data and the uncertainties of the independent measurement equipment (i.e., a 
digital voltmeter and shunt for current measurements).  If the results from this analysis 
show poor accuracy or repeatability, the test equipment should be calibrated and verified 
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again until the results are less than or equal to the claimed values of the manufacturer 
(e.g., 0.02% of full scale repeatability). 

These data are also useful in determining the uncertainty range of the performance 
parameters of interest for the life prediction model.  Each performance parameter (e.g., 
resistance, power, capacity, and energy) is a function of voltage and current 
measurements (temperature uncertainty is treated elsewhere).  The uncertainty expression 
associated with that performance parameter can be determined based on the accuracy and 
precision of the voltage and current measurements as determined during the initial 
calibration or in-test calibration checks, and low-order Taylor Series approximations of 
the performance parameter with respect to the independent voltage and current 
measurements.  For example, the uncertainty expression for resistance as defined in the 
USABC Manuals (References 1-4) is given by Equation (13), where VFS and IFS are the 
test channel’s full scale voltage and current range, respectively; %errVCAL and %errICAL 
are the calibration errors due to the independent digital voltmeter and shunt used to 
measure the accuracy during the calibration check; and %errVSTD and %errISTD are the 
standard deviations determined experimentally from the accuracy measurements. 

1
2 2 2

2 2% %
% 2 2 (% ) (% )

( ) ( ) ( ) ( )
STD STD

S FS FS CAL CAL
a b a b

errV errI
R V I errV errI

V t V t I t I t

    
             

(13) 

 

2.5 Robust Regression 

The parameters associated with both the degradation and error models are estimated with 
a robust regression procedure because it has reduced sensitivity to anomalous data (i.e., 
outliers).  Consequently, the parameter estimates are not greatly affected by the outliers.  
Robust regression procedures also are valuable when the error variance is not constant 
across the experimental space, as is the case for the assumed error model in Section 2.4.  
The particular procedure implemented in this manual includes three iterations of 
weighted least-squares regression (Reference 12).  For the first iteration, ordinary least-
squares regression is used (i.e., the relative weights are identical).  For subsequent 
iterations, the weights are based on Tukey’s biweight function (Reference 13).  
Appendices A and B provide more details concerning parameter estimation for the 
linearizable model (Section 2.2) and nonlinear model (Section 2.3), respectively. 

 

2.6 Life Prediction 

The fitted degradation model can be used to estimate the mean lifetime of a cell for given 
stress factor conditions and end-of-life (EOL) criteria.  The EOL criteria will depend on 
the number of stress factors that are included in the life model.  For the example case of a 
single stress factor (temperature) and a performance measure of relative resistance, the 
EOL criterion could be defined as a 30% increase in degradation at a temperature of T0 
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(i.e.,  0;T t  = 1.3 at EOL).  Given the linearized degradation model in Equation (3), the 

resulting estimated lifetime, EOLt̂ , is shown in Equation (14), where 0 1
ˆ ˆ ˆ, ,  and     are the 

estimated parameter values that were determined from the robust linear regression 
approach in Section 2.5 and Appendix A.  Given the nonlinear model form in Equation 

(5), the resulting estimated lifetime is shown in Equation (15), where 0 1
ˆ ˆ ˆ, ,  and     are 

the estimated parameter values that were determined from the robust nonlinear regression 
approach in Appendix B. 

  0 1
0

1ˆ ˆlog 0.3
ˆ exp

ˆEOL

T
t

 



  
    

    
 
  

           (14)   

1
ˆ

0 1
0

1.3 1ˆ
1ˆ ˆexp

EOLt

T



 




 
  

 

                 (15)   

In a more generalized case of the nonlinear model, EOL can also be estimated using a 
“half-the-interval” iterative method.  In this approach, initial boundary conditions are set 
for the minimum and maximum life interval (e.g., 0 and 100 years, respectively).  If the 
calculated mean lifetime of the cell at the midpoint of the boundary values is different 
from the EOL criterion (  0;T t  = 1.3 for relative resistance in this example), the value 

of the midpoint will be deceased or increased depending on whether the calculated life 
capability is greater than or less than the EOL criterion, respectively.  This iterative 
process will continue until the calculated value for the mean lifetime of the cell is within 
a given tolerance of the EOL criterion, at which point the value of time, EOLt̂ , will be 

reported.  If the dependent variable,  tT ; , is a naturally decreasing response instead 
(e.g., relative capacity and relative power), then the logic is reversed when adjusting the 
value of the midpoint. 

 

2.7 Monte Carlo Simulations 

Monte Carlo simulations based on the fitted degradation and error models, in conjunction 
with a variant of the parametric bootstrap procedure (Reference 14), are used to assess 
the uncertainty of the cell life and associated model parameters.  Simulation results 
provide a basis for assessing the quality of the model based on “lack-of-fit” statistics 
(Section 2.8).  Assuming that the forms of the degradation and error models are accurate, 
the simulations can then be used to assess the uncertainty of the mean cell life as well as 
the model parameters estimated from experimental data. 
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Using a performance measure of relative resistance as an illustration, the overall model in 
Equation (1) can be expanded to the form shown in Equation (16), where j represents the 
stress condition and ij represents the ith cell within the jth stress condition.  Yij(t) 
represents the measured relative resistance of the ijth cell at time t and  tX j ;  represents 

the expected relative resistance for cells under the jth stress condition at time t.  ij 
represents the random proportional effect of the ijth cell, and  tij  represents the effect 

of the random measurement errors on relative resistance associated with the ijth cell at the 
initial measurement and at time t.  The last term can be notionally partitioned into two 
terms:      0ij ij ijt t    , where ij represents the effect of the individual 

measurement errors on relative resistance at beginning of life and at time t.  For these 
simulations, the random effects,    tijijij   and ,0, , are assumed to be independent and 

normally distributed each with a mean of zero and variance of 2 2 2,  ,  and    , 

respectively. 

        ttXtXtY ijjijjij   1;;            (16) 

Monte Carlo simulations should be performed with the overall test matrix that is 
developed using the methods provided in the Technology Life Verification Manual 
(Reference 5).  The experimental conditions are designed to adequately assess cell 
chemistries for a given set of stress factors and should include the test duration, RPT 
frequency, number of experimental conditions, and number of cells per condition.  Due to 
resource limitations, not every experimental condition may be verified with actual cell 
testing, but a sufficient subset of the overall test matrix should be conducted to 
adequately fit the degradation and error models using the robust regression techniques 
discussed in Section 2.5.  The general approach for assessing the uncertainty of the life 
estimate is to repeatedly simulate the overall test matrix that was designed based on the 
TLVT approach while also matching the conditions of the actual experiment.  For each 
independent simulation trial (representing a single realization of the complete 
experiment), different random realizations of cell-to-cell effects and measurement errors 
are added to the assumed truth provided by the degradation model that was fitted to the 
actual experimental data.  First, the number of stress conditions that were used (J), the 
number of cells tested per condition Jjn j :1:  , and the times at which the cells were 

measured  Kktk :1:   are identified.  Next, the degradation model for each combination 

of stress condition and measurement time can be computed 
with       KkJjtX kj :1:1:;  .  Finally, using this setup, a number of independent 

trials are completed as follows: 

1. Simulate     Jjni jij :1 with :1:  , where the ij are sampled independently 

from a normal distribution with mean zero and standard deviation,  . 
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2. Simulate       Jjni jij :1 with :1:0  , where the  0ij  are sampled 

independently from a normal distribution with mean zero and standard deviation 
 .  

3. Simulate         KkJjnit jkij :1 and :1 with :1:  , where the  kij t  are 

sampled independently from a normal distribution with mean zero and standard 
deviation  . 

4. Combine the constituent effects from Steps 1 through 3 to form the simulated 
data:            kijijkjijkjkij ttXtXtY   01;;  and ensure that 

  1kij tY  

 
5. Model the collective set of simulated performance data (e.g., relative resistance) 

for the current trial: 
a. Estimate model parameters (degradation and error) 
b. Estimate average cell life 
c. Compute the lack of fit sum of squares ( LOFSS ) (Section 2.8) 

The summary statistics (e.g., standard deviations and order statistics) of model 
parameters, estimated cell life, and LOFSS  across trials can then be computed.  The 

standard deviations of the model parameters and estimated cell life are referred to as 
bootstrap standard errors.  

 

2.8 Lack-of-fit Statistic 

Another important aspect of successfully estimating the mean cell life is to assess how 
well the degradation model fits the experimental data (i.e., the level of performance 
variation observed for cells aged under a common stress condition).  Inaccuracies in the 
degradation model are detected by the lack-of-fit statistic shown in Equation (17), where 
J is the number of stress conditions, K is the number of RPT’s (the beginning of life RPT 
is denoted as RPT0), tjY  is the average  performance measure (e.g., relative resistance) of 

the jth stress group at RPTK corresponding to some time t (consisting of njt cells), jt̂ is 

the fitted degradation model for the jth stress group at RPTK , and  2ˆ jt is the fitted error 

model for the jth stress group at RPTK, as shown in Equation (18).  Note that Equation 
(17) is normalized by the product of the number of stress conditions and RPTs (JK) to 
enable a comparison across different experiments. 

 2

2
1 1

1
ˆ

ˆ
k

k k

k

J K
jt

LOF j t jt
j k jt

n
SS Y

J K


 
 

  
             (17) 

  2222 ˆ1ˆˆˆ    jtjt              (18) 
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Monte Carlo simulations (Section 2.7) based on the developed degradation and error 
models are used to assess the lack-of-fit statistic.  The value of LOFSS  based on the 

original data is compared with the empirical distribution of the LOFSS  values obtained 

from the simulation trials.  An unusually large value for the lack-of-fit statistic (e.g., 
greater than the 95th percentile of the simulated LOFSS  values) is indicative of model 

inaccuracy. 

 

2.9 Application to Calendar Life Data 

The recommended pathway for demonstrating adequate calendar life of a battery 
technology given a set of experimental data from typical USABC testing (References 1-
4) is as follows: 

1. A deterministic degradation model (Sections 2.2 and 2.3) is developed to reflect 
the average (i.e., typical) cell degradation over time as a function of various stress 
factors such as temperature and state-of-charge.  This model must be accurate 
over the anticipated range of conditions the cells will experience.  It is also 
assumed that the cell technology is sufficiently advanced such that, given a 
standard reference (e.g., 30°C), the model will predict a life capability exceeding 
the target requirement with some significant margin (i.e., the lower confidence 
bound for predicted life must exceed the 15 year goal). 

2. An accurate error model (Section 2.4) is developed to reflect the cell-to-cell 
variability in observed degradation about the average behavior.  This model 
accounts for variability due to measurement error as well as the intrinsic 
differences between cells.  

3. The degradation and error models from Steps (1) and (2) are used as the basis for 
conducting Monte Carlo simulations (Section 2.7) to assess the lack-of-fit statistic 
(Section 2.8). 

4. If there is no evidence for lack-of-fit, the average cell life is estimated at the lower 
confidence limit via the fitted degradation model.  If evidence of lack-of-fit exists, 
the degradation model may need to be modified and this could require additional 
testing with extra experimental conditions. 

5. Adequate calendar life of a battery technology is demonstrated if the lower 
confidence limit bound of the estimated cell life exceeds the requirement. 
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3. APPLICATION 

Both the linearizable and nonlinear modeling methodologies described in Section 2.0 can 
be illustrated using test data acquired from high-power SAFT VL7P lithium-ion 
cylindrical cells (Reference 6).  The primary purpose of the cell testing activities 
described in this section was to demonstrate the accelerated aging methodology presented 
in the TLVT Manual (Reference 5).  Section 3.1 describes the experimental test setup for 
these cells.  The resulting model fits of the experimental test data based on the default 
linearizable and nonlinear models are then presented in Sections 3.2 and 3.3, respectively. 

 

3.1 Experimental 

Experimental testing was conducted with high-power SAFT VL7P lithium-ion cylindrical 
cells that were rated at 7.0 Ah with a voltage range of 4.0 to 2.7 V (Reference 6).  Cell 
aging at the Idaho National Laboratory (INL) was conducted with a Maccor series 4000 
battery tester having a maximum voltage and current rating of 10 V and 12.5 A, 
respectively.  The cells were also placed in temperature chambers that maintained 
ambient conditions to within ±3°C of the target during testing.     

The experimental matrix is shown in Table 3.1 and consisted of 30 cells with three cells 
per test condition.  Accelerated aging was performed at three temperatures (40, 47.5, and 
55°C) and three SOCs.  The SOC conditions centered on the “maximum SOC” (i.e., 
SOCMAX) which was defined at 62% (Reference 6).  As such, the other two SOC 
conditions per temperature group (i.e., SOCMAX - 10% and SOCMAX + 10%) were 52 and 
72%, respectively.  Only the 62% SOC condition was used for the reference temperature 
of 30°C.  All cells were subjected to calendar-life aging at the target temperature and 
SOC with reference performance tests every 31.5 days. 

Table 3.1. SAFT VL7P cell test matrix 

Group # Temperature 
State-of-
Charge 

Cells 

1 30oC SOCMAX 3 

2  40oC SOCMAX -10% 3 

3 40oC SOCMAX 3 

4 40oC SOCMAX+10% 3 

5 47.5oC SOCMAX-10% 3 

6 47.5oC SOCMAX 3 

7 47.5oC SOCMAX+10% 3 

8 55oC SOCMAX-10% 3 

9 55oC SOCMAX 3 

10 55oC SOCMAX+10% 3 
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The SAFT VL7P cells were first characterized with four C1/1 static capacity tests, each of 
which consisted of a constant current discharge at the rated value of 7.0 A to the 
minimum voltage from a fully charged state.  This was followed by a low-current hybrid 
pulse power characterization (L-HPPC) test using the procedures defined in the HEV 
Manual (Reference 2).  The final characterization test consisted of discharging the cells 
from a fully charged state in 5% depth-of-discharge (DOD) increments with a one hour 
rest in between each increment to establish the relationship between SOC and the open-
circuit voltage. 

Calendar-life testing consisted of resting the cells at the designated SOC (based on the 
corresponding open-circuit voltage) and test temperature.  The cells were soaked at the 
target temperature for at least eight hours prior to the start of a calendar-life test to ensure 
thermal equilibrium.  Once every 24 hours during aging, the cells were taper charged 
back to the target open-circuit voltage condition.    Reference performance tests were 
conducted at 30°C and consisted of a modified L-HPPC test as defined in Reference 6.  
The model fits described below are based on changes in relative resistance over seven 
RPTs (i.e., approximately 221 days of calendar-life aging at accelerated test 
temperatures). 

 

3.2 Linearizable Model 

For the linearizable model form in Equation (2), robust linear regression (Section 2.5, 
Appendix A) was used to estimate the model parameters (   and , , 10 ) using relative 

resistance as the performance measure.  The fitted degradation model is given in 
Equation (19), where the resulting parameter estimates and associated standard errors are 
in Equation (20).  These parameter estimates were based on the acquired experimental 
data at the elevated test temperatures (i.e., 40oC, 47.5oC, and 55oC).  All of the SOC 
conditions at each temperature were used to estimate the model parameters since the 
effect between SOCMAX, SOCMAX - 10%, and SOCMAX + 10% was not statistically 
distinguishable (Reference 6).  From these estimates, the data clearly describe a diffusion 
controlled process governed by parabolic kinetics since ̂  0.5.  Figure 1 shows the 
experimental test data and the corresponding linearized model fit; the temperature groups 
are shown in units of Kelvin (e.g., “328.0” refers to the 55°C temperature conditions, 
etc.).  The model prediction at the reference temperature of 30°C is also included and, as 
shown, appears to be a good fit for the experimental data. 

   ˆ
10

1ˆˆexp1;ˆ t
T

tX 






                                                                                   (19) 

 
 

0

1

ˆ 18.60 1.2  

ˆ 6360 393

ˆ 0.5285 (0.021)








 



                  (20) 
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 Figure 1.  Fitted linearized model versus experimental data 

The error model described by Equation (8) was also fit to the experimental data at the 
elevated test temperatures using robust linear regression.  Figure 2 shows the resulting 
error model fit and the estimated parameters are shown in Equation (21).  From these 
estimates, it can be inferred that the cell-specific proportional effect has a standard 
deviation of about 0.06 while the measurement error has a relative standard deviation of 
about 0.01.  Although this implies that the linearizable degradation model matches 
relatively well with the experimental data, significant lack-of-fit was detected using the 
methodology described in Section 2.8.  The value of LOFSS  from Equation (17) based on 

the experimental data was 1.5158.  This result exceeded the 97th percentile of LOFSS  

values obtained with the simulation trials, which is indicative of model inaccuracy.  The 
lack of fit can be observed, for example, in Figure 1 at the highest temperature (55ºC) 
where the model tends to under-predict the observed resistance gain at two months while 
over-predicting the observed resistance gain at six months. 
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                        (21) 

 
Figure 2.  Fitted error model for linearizable case

 
Nevertheless, despite the evidence for lack-of-fit, the fitted degradation model can be 
used to estimate the mean lifetime of the cells to demonstrate the approach described in 
Section 2.6.  Assuming the EOL criterion is defined to be a 30% increase in relative 
resistance at the reference temperature of 30°C, the resulting life prediction is shown in 
Equation (22), where the value of temperature is in units of Kelvin (i.e., 303 K).  Using 
the model parameter estimates in Equation (20), the estimated mean lifetime of the cells 
is ÊOLt = 9.4 years.  The bootstrap methodology (Reference 14) can then be used to assess 

the statistical uncertainty in the predicted lifetime.  Figure 3 shows results of 1000 
bootstrap simulations for the VL7P experimental cell data based on the linearized 
degradation model (Reference 6).  Figure 4 provides a graphical representation of the 
resulting weighted average for the mean cell lifetime capability at the reference 
temperature of 30°C with the corresponding upper and lower confidence levels.  The 95% 
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lower confidence level is 7.9 years since 950 of the 1000 simulation results exceeded that 
life estimate.  The 95% upper confidence level is 12.5 years since the predicted mean life 
for 50 of the 1000 simulations results showed higher estimates.  The combination of the 
95% upper and lower confidence limits results in an overall 90% confidence interval 
between 7.9 and 12.5 years of life.  These confidence levels are consistent with the 
estimated mean lifetime of 9.4 years using the model parameter values.  The weighted 
average of 9.8 years is based on the bootstrap simulations of the experimental data and 
should be reasonably close to the estimated mean lifetime.  

1
0

ˆˆlog(0.3) 303
ˆ exp 9.4 yrs

ˆEOLt





  
       

 
  

               (22) 

 
Figure 3.  Histogram of simulated life capability using 1000 bootstrap trials for the 

linearizable model 

 
Figure 4.  Estimate mean cell life capability with statistical confidence levels for the 

linearizable model 
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3.3 Nonlinear Model 

For the nonlinear model form in Equation (5), robust nonlinear regression (Section 2.5, 
Appendix B) was used to estimate the model parameters (   and , , 10 ) using relative 

resistance as the performance parameter.  The fitted degradation model is given in 
Equation (23), where the resulting parameter estimates and associated standard errors are 
in Equation (24).  As with the linear model fit, these parameter estimates were based on 
the acquired experimental data at the elevated test temperatures (i.e., 40oC, 47.5oC, and 
55oC) and all three of the SOC conditions.  Figure 5 shows the experimental test data and 
corresponding nonlinear model fit.  The model prediction at the reference temperature of 
30°C is also included and, as shown, appears to be a good fit for the experimental data. 

 Figure 5.  Fitted nonlinear model versus experimental data
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The error assessment for the nonlinear model follows the same approach as the 
linearizable case, where Equation (8) is used to fit the experimental data at the elevated 
test temperatures using robust linear regression.  Figure 6 shows the resulting error model 
fit and the estimated parameters are shown in Equation (25).  As with the linearizable 
case, the cell-specific proportional effect has a standard deviation of about 0.06 while the 
measurement error has a relative standard deviation of about 0.01.  However, there was 
no evidence of lack-of-fit for the nonlinear model, with an SSLOF value of 0.509, as 
determined from Equation (17).  This value was exceeded by more than the 90% of the 

LOFSS  values obtained via the simulation trials.   

2 3

2 4

ˆ 2.9x10

ˆ 1.3x10
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






                          (25) 

The closer fit is not surprising given the additional flexibility of the nonlinear model.  
However, one of the negative tradeoffs associated with the nonlinear approach is the 
additional computational expense required (mainly associated with the simulations), 
especially in the cases where the initial guesses for the parameter values are not 
reasonably close to the final estimate.  Additionally, interpretation of the nonlinear model 
can be somewhat more difficult and should typically require a physical basis for its 
development. 
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Figure 6.  Fitted error model for nonlinear case

 
The calculated mean cell lifetime (Section 2.6), assuming an EOL criterion of 30% 
increase in relative resistance at To = 30°C (i.e., 303 K), is shown in Equation (26).  
Given the model parameter values in Equation (24), the estimated cell life capability is 

ÊOLt = 12.9 years.  Figure 7 shows the histogram resulting from the 1000 bootstrap 

simulations based on the nonlinear degradation model and Figure 8 provides a graphical 
representation of the corresponding statistical confidence window.  The 95% lower 
confidence level is 10.1 years since 950 of the 1000 simulation results exceeded that life 
estimate.  The 95% upper confidence level is 17.0 years since the predicted mean life for 
50 of the 1000 simulations results showed higher estimates.  These confidence levels are 
consistent with the estimated mean lifetime of 12.9 years based on the model parameter 
estimates.  The weighted average using the 1000 bootstrap simulations is 13.1 years. 
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Figure 7.  Histogram of simulated life capability using 1000 bootstrap trials for the nonlinear 

model 

 
Figure 8.  Estimate mean cell life capability with statistical confidence levels for the nonlinear 

model 
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4. RATE-BASED DEGRADATION MODELING 

4.1 Methodology 

The change in cell performance over time is typically expressed in terms of a cumulative 
degradation model that is formulated in terms of exposure to a constant stress (see 
Sections 2 and 3) and the models are generally used to predict degradation in well-
controlled conditions.  However, another critical component of successful battery life 
estimation is a model that can account for cell aging under non-steady state conditions.  
In automotive (and other) applications, for example, cells are usually deployed in non-
isothermal environments.  Thus, in these cases it may be more useful to consider a 
different modeling framework based on the instantaneous degradation rate of a cell rather 
than cumulative level of degradation.  Due to their form, such models naturally facilitate 
the prediction of the cumulative degradation in non-isothermal conditions (Reference 7). 
 
Rate-based models can come in various forms and have an empirical, semi-empirical, or 
physical basis (an example model with a physical basis is provided below).  If the 
degradation behavior is memoryless (i.e., path independent), then the instantaneous 
degradation rate at a point in time will depend only on the present level of the 
degradation state and the present stress that is applied to the cell.  If the degradation has a 
memory effect (i.e., path dependent), then the details of the stressing history must also be 
considered in the model.  Path dependent experimental test data require a physical basis 
in the rate-based model to properly account for the mechanistic changes that have 
occurred in the cell chemistry.  Memory effects could come from various conditions such 
as periodic off-normal testing (e.g., at low temperatures) or by the onset of cell failure 
mechanisms (e.g., an internal soft short). 
 
A generalized rate-based empirical model form for of a path independent, or memoryless, 
degradation is shown in Equation (27), where  is the performance measure (i.e., relative 
resistance in the example case) and temperature, T, is the sole stress factor.  The 
cumulative degradation over the temperature profile  t,T 0 is represented by Equation 

(28).  The model parameters, p,,,  21 , must be estimated from cell experimental 

data that are accumulated from the RPTs as a function of aging.   
 

  ,
d

g T t
dt

                          (27) 
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pT t g T d                         (28) 

To illustrate, let Yij be the jth measurement of the ith cell (for i = 1:N and j = 1:ni), tij be the 
time at which Yij  was acquired, and T [0, tij] be the temperature profile experienced by 
the ith cell through tij.  The collection of data can then be compactly expressed by 
Equation (29).  Given estimates for the model parameters ( p ˆ,,ˆ,ˆ 21  ), the predicted 

value of each observation (e.g., ith cell through tij) can be obtained by numerically 
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integrating the derivative function in Equation (30) over the temperature path as 
expressed in Equation (31).  The process for the numerical integration of the derivative 
function is provided in Table 4.1.  Model parameter estimates will likely involve 
nonlinear regression and will need to compute  (for all i and j) repeatedly to find the 
values of  that minimizes some objective function that is expressed in 

terms of the differences between ijij YŶ  and . 
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Table 4.1. Integrating the derivative function numerically 
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4.2 Application: Non-Isothermal Aging 

The purpose of the cell testing activities described in this section was to assess the 
memory effects (if any) of lithium-ion cells that are aged at varying temperatures.  Rate-
based modeling tools were used to develop a degradation model and predict life 
capability with the bootstrap approach (Reference 14).  Cell testing was performed at 
both the Idaho and Argonne National Laboratories (INL and ANL, respectively).  This 
study represents one of the path dependence studies recommended by the Technology 
Life Verification Test (TLVT) Manual (Reference 5).   Other path dependence studies can 
include intermixing calendar and cycle-life aging protocols or varying SOC conditions. 
Additionally, interaction between these various path dependence studies could be 
investigated as well. 

4.2.1 Experimental 

Cell testing was conducted with commercially available, high-power Sanyo SA lithium-
ion cells, which consist of a Li(Mn, Co, Ni)O2 + Li-Mn-O spinel cathode and a graphite 
anode (Reference 17).  They are 18650-size (i.e., 18 mm diameter and 65 mm length), 
with a rated capacity of 1.2 Ah and a voltage range of 4.2 to 2.7 V.  Cell aging at INL 
was conducted with a Maccor series 4000 battery tester having a maximum voltage and 
current rating of 10 V and 12.5 A, respectively.  The cells were placed in Tenney Junior 
temperature chambers that maintained ambient conditions to within ±3°C of the target 
during testing.  Cell aging at ANL was conducted with an Arbin tester having a 
maximum voltage and current rating of 10 V and 25 A, respectively.  The cells at ANL 
were also placed in Tenney Junior temperature chambers.   

The test matrix is shown in Table 4.2 and consisted of 24 cells with three cells per test 
condition.  Both INL and ANL had control groups (i.e. isothermal conditions) at 45 and 
55°C to establish the baseline performance at each temperature.  The first non-isothermal 
group (“Switch”) consisted of calendar-life aging at 55°C until the power fade reached at 
least 15% and then switching to 45°C for the remaining calendar aging (ANL performed 
the same test, but with the temperatures reversed).  The other non-isothermal group 
(“Pulse”) consisted of switching between 55 and 45°C during calendar life aging after 
each RPT.  All cells were subjected to calendar-life aging at 60% SOC (3.89 V) with 
reference performance tests every 32 days.   

The Sanyo SA cells were first characterized with three C1/1 static capacity tests (i.e., a 
constant current discharge at the rated value of 1.2 A to the minimum voltage from a 
fully charged state).  This was followed by a constant power discharge at a scaled, 10-kW 
level; given a sizing factor of 1400 for these cells (Reference 17), the applied constant 
power level was 7.14 W.  Next, a low-current hybrid pulse power characterization test 
(L-HPPC) was performed using the procedures defined in the PHEV Manual (Reference 
1).  The final characterization tests included a C1/25 static capacity test (i.e., a full 
discharge and charge at 1/25th of the rated current, 1.2 A / 25 = 48 mA) and an AC 
impedance sweep at 60% SOC over a frequency range of 100 kHz to 10 mHz with ten 
points per decade of frequency. 
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Table 4.2. Sanyo SA cell test matrix for memory study 

Lab Group # Type Label Cells 
Temp. 
(°C) 

INL 

1 ISO-LO Control 3 45 

2  ISO-HI Control 3 55 

3 NON-ISO Switch 3 55  45 

4 NON-ISO Pulse 3 55 / 45 

ANL 

5 ISO-LO Control 3 45 

6 ISO-HI Control 3 55 

7 NON-ISO Switch 3 45  55 

8 NON-ISO Pulse 3 45 / 55 
 

Calendar-life testing consisted of resting the cells at an open circuit voltage condition at 
the designated test temperature provided in Table 4.2.  A pulse-per-day was also 
performed on the cells using the profile shown in Figure 9 (Reference 1).  This profile 
consists of the standard L-HPPC pulse profile (with a slightly longer rest step) followed 
by a 300-s voltage clamp pulse where the cells brought back to the designated voltage 
corresponding to 60% SOC.  The cells were soaked at the target test temperature for at 
least 4 hours prior to the start of each calendar-life test to ensure thermal equilibrium.  
Reference performance tests were conducted at 30°C every 32 days during aging.  The 
RPTs consisted of a scaled, 10-kW constant power discharge, L-HPPC, and an AC impedance 
sweep at 60% SOC over a frequency range of 100 kHz to 10 mHz. 
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Figure 9.  Calendar-life pulse-per-day profile (Reference 1) 



 25

4.2.2 Results 

This section provides preliminary rate-based modeling approaches for relative resistance 
using a selected subset of the experimental data (i.e., the INL cell groups) and illustrates 
the overall methodology for life estimation.  A simple rate-based model form is shown in 
Equation (32).  Using numerical integration and nonlinear regression, the model 
parameter fits to the experimental data are provided in Equation (33).  Figure 10 shows 
the test data and corresponding model fits.  Overall, the rate-based model matches the 
data reasonably well.  The Sanyo SA cells have completed six RPTs and the “Switch” 
group that was initially aged at 55°C surpassed 15% power fade after the third RPT. 
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Figure 10.  Simple rate-based model fit to the INL experimental data 

Estimates of the error model parameters from Equation (8) above are provided in 
Equation (34).  From these estimates, both the cell-specific proportional effect and 
measurement error have relative standard deviations of about 0.01.  Although this seems 
to indicate a reasonable fit, a moderate level of lack-of-fit was indicated using the 
statistical analysis presented in Section 2.8.  The value of LOFSS  from Equation (17) 
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using the experimental data was 2.6, which exceeded the 98th percentile of LOFSS  values 

obtained from the simulation trials.  The lack of fit can be observed in Figure 10, where the 
model tends to under-predict the observed resistance gain beyond 0.4 years at 55°C. 
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A more generalized form of the rate-based model (Reference 7) is shown in Equation 
(35), where k(T) is defined in Equation (36).  The physical basis for this model is 
analogous to the high-temperature oxidation of metals, such as niobium and cerium 
(References 15 and 16), where there were significant changes in the diffusion rate at 
which the materials react at different times due to structural changes in the oxide scale.  
Using this mechanism in lithium-ion cells, the products that form in the solid electrolyte 
interphase (SEI) layer may structurally change with time as the reaction proceeds.  The 
resulting fitted model parameter values based on numerical integration and nonlinear 
regression are provided in Equation (37) and Figure 11 shows that the 55º C data now 
more accurately matches the model compared to the simpler model in Figure 10.  A 
negative value for ̂  indicates that the rate of degradation increases with age.  Estimates 
of the error model parameters are provided in Equation (38), where both the cell-specific 
proportional effect and measurement error have relative standard deviations of about 
0.01. However, there is still some evidence for lack-of-fit since the calculated value for 
SSLOF was 2.15, which exceeded the 96th percentile of LOFSS  values obtained from the 

simulation trials. 
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The 2010 hourly ambient temperature profile from Phoenix, AZ is used to illustrate life 
estimations under non-isothermal conditions based on the rate-based approach (Reference 
7).  Figure 12 shows the year-long temperature profile.  From the generalized form of the 
fitted model in Equation (35) and parameter estimates in Equation (37), the predicted 
increase in relative resistance assuming repeated instances of this temperature profile 
(beginning on January 1) is provided in Figure 13.  The resulting mean cell life (i.e., 
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when the relative resistance first exceeds 1.3), is estimated to be about 4.5 years.  Figure 
14 shows the empirical cumulative distribution function of end-of-life values obtained 
from the bootstrap simulation.  These data indicate that the 95% upper and lower 
confidence bound for the mean lifetime of the cells is 4.75 and 3.7 years, respectively. 
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Figure 11.  Generalized rate-based model fit to the INL experimental data 
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Figure 12.  Hourly temperature profile: Phoenix, AZ, Calendar year 2010 
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Figure 13.  Predicted rise in relative resistance 
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Figure 14.  Cumulative distribution function of predicted mean life from bootstrap 
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5. BATTERY LIFE ESTIMATION SOFTWARE 

The purpose of the BLE software package (http://www.anl.gov/techtransfer/ 
Software_Shop/TLVT/TLVT.html) is to facilitate the analysis of simulated and 
experimental test data.  The software captures all of the mathematical analysis and life-
simulation tools described in this manual as well as the default degradation and error 
models described in Section 2.  This section provides a description of the software 
contents and a user’s guide to running the application. 

 

5.1 System Requirements 

The minimum system requirements for the BLE software package are a PC computer 
with a Pentium 4 processor with at least 1 GB of memory and VGA graphics. There 
should also be a minimum of 3 MB of free space on the hard disk. 

The software has been extensively tested on Windows XP and on Windows 7. The 
Microsoft .NET framework version 4 Client Profile must be installed for the software to 
operate. The minimum system requirement for the .NET 4 is Windows XP SP3. It will 
operate with the other .NET 4.0 profiles. To download and install the .NET Framework 
4.0, go to the following website and click on "DOWNLOAD."  The program will also 
function if you install the full .NET Framework 4 instead. 

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17113 
 

5.2 Battery Life User Interface 

The BLE software application is designed to be very user-friendly.  All functions are 
accessible through menus and data-entry forms.  When the application starts, the blank 
desktop, shown in Figure 15 will appear.  The main menu consists of five choices: File, 
Edit, Run, View and Help.  A detailed description of these menu choices are provided in 
Section 5.5. 

  
Figure 15.  A screen view of the “Battery Life Estimation” desktop 
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5.3 Equation Requirements 

The data to be fit or modeled must at least be time-based (i.e., time is an independent 
variable); other variables, such as temperature and energy could also be included.  A 
maximum of 100 variables can be used in the model equation. 

The model equation can be linearizable, as described in Section 2.2.  For this approach, 
the degradation model must be re-expressed with linear transformations, where each 
transform consists of only one independent variable.  Consequently, the number of 
transform equations for the linearized form is based on the number of independent 
variables in the model equation.  For example, the expression R = A + B/T + Ctz with A, 
B, and C as the fitting coefficients has the linear transform equations of R, 1/T, and tz. 

A more complex expression such as R=Aexp(B/T)tz can be linearized to lnR=lnA + B/T + 
zln(t), but it is not in the proper form because of the lnA term (log of a constant).  The 
original expression should be rewritten as R=exp(A' + B/T)tz, then linearized with lnR=A' 
+ B/T + zlnt with transform equations of lnR, 1/T, and lnt. 

The model equation can also be nonlinear, as described in Section 2.3.  Nonlinearizable 
model equations, such as R ={1+exp(A' + B/T)t}z, do not require transformations, but 
initial guesses for the model parameters must be provided to the software for the 
regression analysis.  These equations can be as complex as needed, but overly-complex 
equations will not work (see below). 

 

5.4 Data Formatting Requirements 

It is assumed that the data to be fitted are arranged in columns (e.g., in EXCEL or plain 
text) with a comma as the delimiter in plain-text files.  A header row at the top of each 
column must be included as well.  The columns do not have to be sequential.  It is further 
assumed that all data to be fit or modeled are time-based and that time is included as one 
of the columns in the discrete variable input file. 

The data to be fit should be normalized to the t = 0 value for each dependent variable of 
the degradation model (Sections 2.2 and 2.3).  However, the beginning of life value (i.e., 
at t = 0) should not be included in the BLE software data file.  If it is not removed, the 
program will filter these values out as well as any dependent variable values that are less 
than zero. 

Table 5.1 shows part of a sample input file arranged in columns with time, temperature, 
and relative resistance.  Note that if there are missing measurements, as shown in the 
second row of data, they must be removed before starting the analysis and simulation 
program.  If they are not removed, an error message will be displayed, stating that there 
are no data available. 
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Table 5.1. Example of data containing a missing measurement 

Time, 
yr 

Temperature, 
K 

Relative 
Resistance

0.1 298 1.02 

0.1 298   

0.1 298 1.01 

0.1 308 1.03 

 

 

5.5 Software Navigation 

This software navigation section details all of the functions of the BLE software tool.  In 
the accompanying description, the "►" symbols indicates a sequence of mouse clicks. 

5.5.1 File Menu 

The File menu is shown in Figure 16 and consists of the following choices: New, Open, 
Save, Save As, Preview Report, Print Report, Exit and Recent files. 

 
Figure 16.  File menu 

File ► New ► Fit.  This option activates the Fit Wizard (Section 5.6.3) and allows the 
user to start a new fit based on a modeling equation and an existing set of data (i.e., from 
a file).  

File ► New ► Simulation.  This option activates the Simulation Wizard (Section 5.6.4) 
and allows the user to start a new Monte Carlo simulation based on a modeling equation.  
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File ► Open (Ctrl+O).  This option opens an existing *.Life file.  The files contain the 
information needed to carry out the fit or simulation or a combination of the two.  If the 
application finds that there is an error in the file, such as it was created by an earlier 
version of the software or is corrupt, the application will display an error. (Section 5.6.1) 

File ► Save (Ctrl+S).  This option saves the existing fit / simulation information for 
later use.  The file is saved to the current filename or to a file called "default.Life." 

File ► Save As.  This option saves the current fit / simulation information for later use.  
The file is saved to a user-defined filename. 

File ► Preview Report.  This option lets the user see the report on the desktop before 
committing it to paper (Section 5.7).  

File ► Print Report (Ctrl+P).  This option lets the user commit the fit / simulation 
calculations to paper.   

File ► Exit (Ctrl+Shift+X).  This option ends the current session. 

File ► Recent files.  This option displays the five most-recent files used or created.  The 
menu item will not be shown until file(s) have been saved or read.  Clicking on a file 
name in the list will open the file for use. 

5.5.2 Edit Menu 

The Edit Menu is shown in Figure 17 and consists of the following choices: Equations, 
Life confidence limit, and Copy view to clipboard. 

 
Figure 17.  Edit menu 

Edit ► Equations (Ctrl+E).  This option starts the equation editor to alter the stored 
equations that are used in the current fit and/or simulation (Section 5.6.3.3). 

Edit ► Life confidence limit (Ctrl+L).  This option changes the lower and/or upper 
confidence limits that are used for the life projections (Section 5.6.2.4). 
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Edit ► Copy view to clipboard (Ctrl+C).  This option copies the contents of the 
current (foremost) view to the Windows clipboard for pasting into other clipboard-aware 
applications, such as EXCEL or Word.  It is copied as a windows metafile if the view 
contains a plot, or as HTML if the view contains text and/or data tables.  Data table 
displays are copied exactly as they appear on the screen. 

5.5.3 Run Menu 

The Run Menu is shown in Figure 18 and consists of the following choices: Fit and 
Simulation. 

 
Figure 18.  Run menu 

Run ► Fit (Ctrl+F).  This option re-runs the present fit. 

Run ► Simulation (Ctrl+Shift+S).  This option displays the sub-menu. 

Run ► Simulation ► Perform Simulation.  This option re-runs the current simulation. 

Run ► Simulation ► Another Life Estimate.  This option allows another life estimate 
to be calculated from the current simulation results. 

5.5.4 View Menu 

The View menu is shown in Figure 19 and consists of the following choices: Results of 
Models, Plot..., and Data.... 

 
Figure 19.  View menu and model results sub-menu 
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5.5.4.1 Results of Models 

The sub-menu for model results is also shown in Figure 19 and consists of the following 
choices: Fitting, and Monte Carlo simulation. 

View ► Results of Models ► Fitting (Ctrl+Shift+G).   This option displays the results 
of the fitting calculations, and includes the model equation, the names and variables used, 
the values of the fitting parameters, the estimate of errors, and lack of fit information 
(Section 5.7.1).   

View ► Results of Models ► Monte Carlo simulation (Ctrl+S).  This option displays 
the results of the Monte Carlo simulation (Section 5.7.2).  

5.5.4.2 Plot 

The plot sub-menu is shown in Figure 20 and has five choices:  Fitting Results, Var(Y) 
vs. ( ̂ -1)², (Y - ̂ ) vs. ̂ , ̂ vs. Y , and Monte Carlo simulation (Section 5.7.2.2). 

 

 
Figure 20. View menu and plot sub-menu 

View ► Plot... ► Fitting Results (Ctrl+Shift+N).  This option produces a plot of the 
experimental data and the fit. 

View ► Plot... ► Var(Y) vs. ( ̂ -1)² (Ctrl+Shift+V).  This option produces a plot of the 
error model results.  

View ► Plot... ► (Y - ̂ ) vs. ̂ .  This option produces a plot of the difference between 
the average, relative value and the fitted value. 

View ► Plot... ► ̂ vs. Y .  This option produces a plot of the fitted value versus the 
average, relative value. 

View ► Plot... ► Monte Carlo simulation (Ctrl+Shift+T).  This option produces a 
cell-distribution bar chart. 
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5.5.4.3 Data 

The data sub-menu is shown in Figure 21 and has two choices:  Input data and model.  
The model sub-menu is also shown in Figure 21 and has three choices: Dependent 
variable, Var(Y), and Monte Carlo simulation.  The label of the dependent variable menu 
item will reflect the fitted response (i.e., the dependent variable, such as resistance, 
capacity, etc.). 

 
Figure 21.  View menu and data sub-menus 

View ► Data ► Input Data.  This option displays the input data, and is useful for 
comparing the known input data to what the software read from the input file.  Figure 22 
shows a sample data display with the proper format discussed in Section 5.4.  The data 
can also be sorted in ascending or descending order by simply clicking on the column 
title.  When the data are sorted by a particular column, a small arrow (▲or ▼) will 
appear that indicates the direction of the sort.  The data displayed in the grid can be 
exported to a comma-separated values (CSV) file by clicking on the "Export>>" button 
on the right hand side, as shown in Figure 22.   

View ► Data ► Model... ► Rel. Resistance.  This option displays the degradation 
parameter data; in this case, it is the relative resistance.  The label will automatically 
adjust to the appropriate parameter being fit or modeled by the software. 

View ► Data ► Model... ► Var(Y).  This option displays the variance of the output 
data.  

View ► Data ► Model... ► Monte Carlo simulation.  This option displays the results 
from the Monte Carlo simulation, including the parameter fits, error variances (i.e., 
SIGMA_D is the variance of cell-to-cell effects and SIGMA_E is the variance of the 
measurement error), life projections, and the lack-of-fit sum of squares values generated 
for each simulation trial.  A sample Monte Carlo simulation output is shown in Figure 
23.  The data displayed in the grid can be exported to a CSV file by clicking on the 
"Export>>" button on the right hand side. 
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Figure 22.  Input data display 

 
Figure 23.  Monte Carlo simulation data display 

5.5.5 Help Menu 

The main help screen is shown in Figure 24 and provides a detailed description of the 
program’s capability and navigation. 
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Figure 24.  Software help file 

 

5.6 Using the Software 

5.6.1 Creating or Opening an Existing Fit/Simulation File  

Creating a new fit or simulation (File ► New ►) will immediately launch the 
appropriate fit wizard (Section 5.6.3) or simulation wizard (Section 5.6.4).  When 
opening an existing file (File ► Open), the user will be prompted with a file-selection 
dialog box, similar to that shown below in Figure 25.  The BLE software files are saved 
with a “*.Life” extension and contains information regarding what type of operation is to 
be done (fit, simulation or both) and the values of other parameters used in the program. 
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Figure 25.  File selection dialog box 

5.6.2 Fitting and Simulation 

Once a file has been opened or created, there are three options available in this software 
package for fitting and/or simulating the data: 

1. Fit Only.  This option solves for parameter values based on input data and the 
model equation. 

2. Fit and Simulate.  This option solves for parameter values and simulates life 
based on those fitted values. 

3. Simulate Only.  This option simulates life based on user-provided parameter 
values with the assumption that the fit was completed independent of this 
software package. 

5.6.2.1 Fit Only 

The program will prompt the user to identify the stress factor groups within the dataset to 
include in the fitting process.  A sample dialog box is shown in Figure 26, with 
temperature (in Kelvin) identified as the stress factor of interest.  The user may 
select/unselect the datasets indicated by the experimental stress condition(s) by clicking 
on the check boxes or on the Select All or Unselect All buttons.  Click OK to proceed to 
the fitting process.  The results of the fit can then be seen by clicking on the View menu 
choices (Section 5.5.4). 
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Figure 26.  Include/exclude dataset(s) dialog box 

5.6.2.2 Fit and Simulation 

The program first proceeds through the Fit Only function described in Section 5.6.2.1 
above, and then prompts the user to run the simulation.  The dialog then becomes similar 
to that found in the Fit Wizard discussion (Section 5.6.3), followed by the Simulation 
Wizard (Section 5.6.4).  The results of the fit and simulation can be seen by clicking on 
the View menu choices (Section 5.5.4). 

5.6.2.3 Simulation only 

The dialog is very similar to the Fit and Simulation description in Section 5.6.2.2 above, 
except that no fitting is performed and must be provided by the user.  The results of the 
simulation can then be seen by clicking on the View menu choices (Section 5.5.4). 

5.6.2.4 Life Confidence Limits 

There are two types of life projections that can be performed with this program, one 
based on experimental data (Section 5.6.2.2) and the other based on hypothetical data 
simulated from the life equations (Section 5.6.2.3).  The difference between the two types 
of projections is in how they use confidence limits.  The projection based on 
experimental data uses an upper confidence limit (UCL) and a lower confidence limit 
(LCL); the one based on simulations just uses the lower confidence limit.  A typical 
display to change just the lower confidence limit is shown in Figure 27.  The life 
projection will then be calculated using the input value(s), then displayed on subsequent 
dialogue boxes and reports. 
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Figure 27.  Editing the lower confidence limit 

5.6.3 Fit Wizard 

The Fit Wizard assumes that time is an independent variable for all modeling equations.  
The fitting process is as follows: 

1. Specify the data to be fit  

2. Associate variables to the data parameters 

3. Specify the life equation and the corresponding transforms using the identified 
variables 

4. Import test data from file 

5. Identify stress factor combination(s) to include in the fit 

6. Perform the fit 

With each dialog box in the Fit Wizard, the user can move forward by clicking the 
“Next” button.  If not all of the entries were appropriately filled, the software will prompt 
the user for the missing information.  To update or modify a previous entry, press the 
“Back” button to return to the previous screen. 

5.6.3.1 Defining the Data 

The first step in the fitting process is to define the type of data that are used for the fit. 
Figure 28 shows the list of available dependent and independent variables in the software 
tool.  The dependent variables include resistance, capacity, energy, and power, and only 
one can be selected per fit.  The independent variables include time, temperature, state-
of-charge (SOC), power, energy, capacity, discharge cutoff, and charge cutoff.  More 
than one independent variable can be chosen per fit, and they can be selected by clicking 
on the variable name.  For example, a total of three variables (one dependent, and two 
independent) have been identified for the fit in Figure 28.  If a variable name other than 
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those shown in Figure 28 is to be used, click on the "User defined..." button.  This option 
allows any variable name to be used in the application  

 
Figure 28. Typical display to define the data in a file 

5.6.3.2 Associate Variables with the Definitions 

Once the data have been defined, the next step is to assign variables to the parameters.  
Since there are three parameters identified in the example shown in Figure 28, the 
software will prompt the user to identify three algebraic variables, as shown in Figure 
29.  The algebraic variables can be more than one letter and the names are not case-
sensitive (e.g., “t” for time and “T” for temperature will not work).  The first variable 
name in the list is the dependent variable (e.g., resistance).   

All temperatures in the fitting and simulation processes must be in Kelvin.  If the data 
input already has temperature in Kelvin, put a “k” in the “Temperature: Celsius/ Kelvin” 
text box.  Otherwise, place a “c” in the text box, and the software will automatically 
perform the conversion to Kelvin.  

The type of model to be used is also indicated on this diaglog box.  If the model is 
linearizable, click on the "Linear" radio button; otherwise click on the "Nonlinear" radio 
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button.  It should be noted that these choices are mutually exclusive.  Both cannot be 
selected at once. 

The software will not associate any physical process with the name and, hence, does not 
implicitly know if the dependent variable increases or decreases with time.   The 
"Increases with time" box to the right of the dependent variable text box should be 
checked if the dependent variable does increase with time (e.g., it is checked in the case 
of resistance) or unchecked if the dependent variable decreases with time (e.g., capacity 
or power loss).   

At this stage in the software development, only calendar-life data in units of time (e.g., 
weeks, months, years, etc.) are considered for fitting.  At some future date, cycle life data 
should also be implemented in the software tool as well.  The time unit is selected using 
the drop-down box under "Increases with time." 

 
Figure 29. Typical display to associate data and variables  

5.6.3.3 Specify the Equations 

The life and transform equations must be entered next.  The form of the equations must 
be of the appropriate mathematical operations and functions.  The “Help” button will 
identify the available algebraic symbols, as shown in Figure 30.  Do not include an equal 
sign (i.e., “=”) at the beginning of the expression. 

Assuming a linearizable model, Figure 31 shows the dialog box for specifying the 
equation and transforms.  The linearized form of the life equation is entered in the upper 
text box marked “Modeling equation” and the terms of the equation are to be entered in 
the group of text boxes labeled as “Transform equations.”  The number of transform 
equations will depend on the number of independent variables identified in Section 
5.6.3.1.  Using the example variables that have been identified (e.g., resistance, time, and 
temperature), the equation for default model is R = 1+exp(b0+b2/temp)tb1 (i.e., Equation 
(2)).  The “Default Model” button in the dialogue box will automatically fill in the text 
boxes with the appropriate model and transforms using the variable labels identified in 
Section 5.6.3.2.  The linearized form is, therefore, ln(R-1) = b0 + b2/temp + (b1)lnt.  The 
terms containing the three variables are entered in the boxes; the fitting constants, b0, b1 
and b2, are not entered. The order in which the transform equations are entered does not 
matter. The equations are not case sensitive and there is no limit to the number of terms 
in them.  To confine the fit to a predetermined value, (e.g., a fixed power of time such as 



 43

a square-root of time dependence), the fitting equation would be 
R=1+exp(b0+b1/temp)t0.5 and the transform equations would not change. 

The nonlinear form of the life equation is also entered in the upper text box marked 
“Modeling equation,” and must contain all of the independent variables identified in the 
previous step (Section 5.6.3.2).  This model form will not require any transform 
equations.  As with the linearizable model in Figure 31, the “Default Model” button in 
the nonlinear dialogue box will automatically fill in the text box with the model provided 
in Equation (5). 

 
Figure 30. Available algebraic functions 
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Figure 31.  Typical display to specify equations and variable transforms for a linearizable 
model 

It should be noted that there is no default model, linearizable or nonlinear, which depends only on 
time.  In this case, the Default Model button will be grey and inactive.  When the model equation 
is appropriately specified in the dialog box, click on "Next >" and the application will check 
the syntax of the modeling equation and report any errors.  If the modeling equation uses 
negation after an open parentheses, as in “(-B0”, the application will report the error, 
"missing argument near ')'."  This is how the equation parser works.  If the expression is 
preceded, instead, by a space, as in “( -B0”, then no syntax errors will be reported.  After 
the syntax check, a message box will appear to confirm the names of the fitting 
variables.  In the example shown in Figure 31, these are B0, B1 and B2.  Click OK to 
proceed to the next step or Cancel to correct. 

5.6.3.4 Import Test Data 

The next step in the Fit Wizard is to import data from an Excel workbook or comma-
separated value file.  The data must be arranged in columns and normalized to time (t) 
t=0 (see Section 5.4 for data formatting requirements).  Additionally, if the relative 
change between measurements is greater than 50% (increase or decrease), the error 
model strategies will not be applicable and the user will then see a warning to this effect 
and have the option of continuing or not.  Figure 32 shows a typical display for file 
selection.  Only one file can be selected at a time.   

Once a file has been selected, the wizard will produce a display similar to that shown in 
Figure 33.  In this example, an EXCEL workbook was selected as the data file, so the 
worksheets names are shown on the left side of the display. Clicking on the worksheet 
with the data of interest produces a display similar to Figure 34.  If an error was made in 
the file selection, click “Open another file...” to change source data.  A similar display 
will be shown if data are read from a comma-separated-values file. 
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Figure 32. Typical display to select a data file 

 
Figure 33. Typical display to open an Excel file 

 
Figure 34. Typical display for selecting the sheet and columns from an EXCEL data file 
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In Figure 34, the “Use This 2” worksheet is selected. In this case, the program displays 
the contents of the first two rows of the selected sheet in the preview window, allowing 
for easier column selection. Data are selected by clicking on the first cell of the column.  
For the example shown in Figure 34, the relative resistance data are in column C; time, 
column A and temperature, column B. They were selected by clicking on those columns 
in that order. The arrow (>) shows the active variable name.  The columns selected are 
shown in the window on the right side of the display. If a mistake is made, continue 
choosing columns until display cycles back to where the error is and click on the correct 
column.  It is assumed that the time data are in calendar years and that the temperatures 
are in Celsius or Kelvin.  If the temperatures are in Celsius, the program will convert 
them to Kelvin (Section 5.6.3.2).  

5.6.3.5 Select Stress Factor Combinations 

After the data are imported, they will be analyzed and grouped according to the stress 
factors previously identified (see Figure 28).  There is also an opportunity to include or 
exclude a set of stress conditions if the data are not well-behaved.  Figure 35 shows the 
display for this step using temperature as an example stress condition.  Following this 
step, the software proceeds to the fit, and the results can be displayed as shown in Section 
5.7. 

 
Figure 35. Selecting which stress factors to include in the fit calculation 

5.6.4 Simulation Wizard 

Simulation is performed to calculate a life projection based on an assumed model, and, if 
experimental data are available, to judge the lack of fit between the test data and the 
model.  As with the Fit Wizard (Section 5.6.3), the Simulation Wizard assumes time is an 
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independent variable for all modeling equations.  The simulation process is shown below. 
The first three steps are the same as the Fit Wizard, and the corresponding descriptions 
can be found in Sections 5.6.3.1 through 5.6.3.3.  The remaining steps are described in 
this section. 

1. Define the data to be used 

2. Associate variables to the data parameters  

3. Specify the life equation and the corresponding transforms 

4. Enter simulation parameters 

5. Specify simulation conditions 

6. Perform the simulation 

With each dialog box in the Simulation Wizard, the user can move forward to the next 
step by clicking the “Next” button.  If not all of the entries were appropriately filled, the 
software will prompt the user for the missing information.  To update or modify a 
previous entry, press the “Back” button to return to the previous screen. 

5.6.4.1 Enter Simulation Parameters 

The parameters affecting the simulation results are entered using the form shown in 
Figure 36.  Most of the fields will be automatically filled in by the software program 
from the Fit Wizard (Section 5.6.3), though the user must enter a value for the relative 
performance at end-of-life for the selected degradation parameter (e.g. a 30% increase in 
relative resistance resulting in a value of 1.3).  The other fields can also be adjusted as 
necessary.  If, for example, the measurement error is independently determined (Section 
2.4.2), then this value can replace the estimated error calculated from the experimental 
data.  Adjustments to the other parameter values, however, are not recommended if the 
user wants the simulation to replicate the actual experiment as closely as possible.  The 
values for the initial parameter should be filled in based on expected performance.  For 
example, if the model generally assumes a square root of time dependence, the value for 
“B1” in Figure 36 should be close to 0.5.  Additionally, the estimated life of the batteries 
will be compared to the goals established by the U.S. Advanced Battery Consortium 
(USABC); in this case, the goals are associated with a hybrid-electric vehicle (HEV).  
The established vehicle goals for both calendar and cycle life are selected by the Goals 
drop-down box. 
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Figure 36.  Display allowing entry of simulation parameters 

5.6.4.2 Specify Simulation Conditions 

The experimental conditions (temperature, duration, number of cells, etc.) are then 
specified for all groups, as indicated in Figure 37.  There is no limit to the number of 
groups that can be used, but the total number of cells in the simulation is limited to 500.  
The Monte Carlo simulation parameters for life prediction are also entered at this stage.  
These values include the temperature (in Kelvin), the upper and lower confidence limits, 
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and the number of simulation trials.  Click on “OK” to perform the simulation and life 
prediction.  

 
Figure 37.  Experimental conditions and Monte Carlo parameter entry 

5.6.5 Model Fit Results 

The results from the model fit can be found by clicking on View ► Results of Models 
► Fitting (Ctrl+Shift+G).  An example result is shown in Figure 38 and includes the 
model equation, the names and variables that were used, the values of the fitting 
parameters, the estimate of errors, and lack-of-fit information.  The values given in 
parentheses for each of the fitting parameters are the bootstrap standard errors determined 
from the Monte Carlo simulations.  The values given in the error model section, σε

2 and 
σδ

2, represent the variances of the measurement error and cell-to-cell effects, 
respectively.  They are derived from the regression of the variance of the experimental 

dependent variable, Y, on  2
1 ˆ , where ̂  is the predicted value of Y.  The values for 

Var(Y) and ̂
 
are computed for each experimental condition (e.g., temperature/time) to 

form the data set used in this regression.  Alternatively, the measurement error will reflect 
the independently determined value, as discussed in Section 2.4.2. 

The value of the lack-of-fit statistic obtained with the actual data is compared with the 
empirical cumulative distribution function (CDF) of the values obtained from the 
simulation trials to assess model inaccuracy.  If the lack-of-fit statistic obtained with the 
actual data exceeds the percentile of the simulated values, then it can be concluded that 
the model is inaccurate.  Normally, a small value for  is selected (e.g., 0.01).  In 
practice, the CDF is evaluated at the value of the lack-of-fit statistic ( LOFSS ) obtained 

with the actual data.  If the evaluated CDF point exceeds (1-), then it is concluded that 
there is evidence for lack of fit.  Pressing the "View CDF" button will display the 
empirical CDF curve and the evaluated CDF point as shown in Figure 39.  The empirical 
CDF curve may take some time to display fully. 
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Figure 38.  Example results from fitting display 
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Figure 39.  Example CDF curve 

5.6.6 Monte Carlo Simulation Results 

5.6.6.1 Life Estimation 

The results of the Monte Carlo simulation can be found by clicking on View ► Results 
of Models ► Monte Carlo simulation (Ctrl+Shift+S).  Figure 40 shows an example of 
life estimation when using experimental data (i.e., a life estimate with an upper and lower 
confidence limit).  If a life estimate is based only on simulation data, the resulting 
prediction will typically be displayed as shown in Figure 41. 

 
Figure 40.  Life estimate display using experimental data 
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Figure 41.  Typical life projection result display from Monte Carlo simulation 

5.6.6.2 Data Plots 

As mentioned in Section 5.5.4.2, there are five data plots available in the View ► Plot... 
► menu option.  Figures 42 through 47 show representative plots for each of the 
available options based on a set of experimental test data and a linearizable parameter fit 
using the default model in Section 2.2.  A sample Fitting Results plot, which includes 
both experimental data and the resulting model fit, is shown in Figure 42.  The numbers 
on the right of the model output indicate the corresponding test temperature (in Kelvin).   

 
Figure 42.  Experimental data and fitted curves 
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An example plot of the error model results (i.e., Var(Y) vs. ( ̂ -1)²) is shown in Figure 

43, where ̂  is the estimated performance.  A plot of (Y - ̂ ) vs. ̂ is shown in Figure 

44, where Y is the average relative value and ̂  is the estimated value.  A plot of ̂ vs. 

Y is shown in Figure 45.  Finally, there are two different viewing options for the Monte 
Carlo simulation.  Figure 46 shows the sample cell-distribution bar chart and Figure 47 
displays the same data as a smooth curve.  These plots indicate that over 50% of the cells 
have a predicted life of about 10 years or more. 

 

 
Figure 43.  Error model results 
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Figure 44.  Difference between average and predicted performance vs. predicted performance  

 
Figure 45.  Predicted performance behavior vs. the average measured performance 
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Figure 46.  Cell distribution bar chart 

 
Figure 47.  Cell distribution bar chart as a smooth curve 
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5.6.7 Report Preview 

A preview of the results assembled by the software can be found by clicking File ► 
Preview Report (Section 5.5.1).  The first page of a sample report is shown in Figure 
48.  This is useful in viewing the report prior to printing it on paper.  The '<Prev' and 
'Next>' buttons on the upper left allow navigating between and among a multi-page 
report. 

 
Figure 48.  Report print preview 
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5.7  Troubleshooting 

The following section identifies known issues with the software development as of the 
publication of this manual, and their associated solutions. 

5.7.1 Text-entry boxes and/or buttons are not in the correct positions or 
appear to be crowded 

Solution:  Change the settings for the display.  Close the application.  Right click on the 
desktop and select properties.  Click on the tab that says Settings.  Click on the button 
that says Advanced.  Change the DPI setting in the Display group box to 96 DPI.  Click 
OK twice. 

5.7.2 The application is running on a network and an error occurs when 
trying to open a Life file 

Solution:  A message box similar to the one shown in Figure 49 should appear.  This 
error occurs only when the application is running on an intranet.  Download the .NET 2.0 
SDK from Microsoft and follow the install instructions given in 
http://technet.microsoft.com/en-us/library/bb742442.aspx.  Reboot the computer.  Click 
Start -> Programs -> Administrative Tools -> Microsoft .NET Framework 2.0 
Configuration.  Click on the 2.0 Configuration snap-in followed by OK.  Click on 
Configure Code Access Security Policy -> Adjust Zone Security -> Make changes to this 
computer -> OK -> Local intranet.  Move slider to Full Trust.  Click Next -> Finish.  
Close the configuration tool window.  The application should run normally now. 

 
Figure 49.  Network error box 
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Appendix A 

Methods for Estimating the Parameters of Linear Models 

1. INTRODUCTION 

This appendix summarizes the statistical methodology used for estimating the parameters 
associated with linear degradation and error models.  A linear model that can be 
represented by the form shown in Equation (A1) is assumed, where Z is a response 
variable, the Xi’s represent M explanatory variables, and the i’s are model parameters 
which are to be estimated.  To achieve this linear form, it may be necessary to transform 
the natural response and/or one or more of the natural explanatory variables to a linear 
form.  For example, the response could be transformed as shown in Equation (A2), where 
Y is the underlying performance metric (e.g., relative resistance).  Other transformations 
could also be applied to explanatory variables, such as the inverse temperature. 

MM XXXZ   22110           (A1) 

 1log  YZ               (A2) 

For estimating model parameters (i), it is assumed that there are N observations, each 
containing the observed value of the response variable, Z, and the associated values of the 
explanatory variables, Xi (e.g., inverse temperature).  Thus, the data consist of a set of 
observations, as shown in Equation (A3).  The model parameters are then estimated by 
using a robust linear regression procedure (Reference 12).  The purpose of using a robust 
regression procedure rather than ordinary least squares is to reduce the influence of 
anomalous data on the parameter estimates. 

         NiiXiXiXiZ M ,,2,1:,,,; 21             (A3) 

An illustrative example of this methodology is provided in Reference 6. 

2. ROBUST LINEAR REGRESSION 

Two specific cases for estimation are considered.  In the first case, the model contains an 
intercept term (0).  Here, the initial step is to compute the average and standard 
deviation of each of the explanatory variables, Xi.  This yields  MXXX ,,, 21   

and MSSS ,,, 21  , respectively.  These explanatory variables are then mean-centered 
and scaled as shown in Equation (A4).  Therefore, in the case with an intercept, the 
design matrix (D) has a size of “N by M+1”, and is of the form shown in Equation (A5).   

   
j
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j S

XiX
iX


*              (A4) 



 63

   

   





















NXNX

XX

D

M

M

**
1

**
1

1

111







           (A5) 

In the second case for estimation, the model does not contain an intercept.  Here, the 
explanatory variables are not mean-centered and/or scaled, and the design matrix (D) has 
a size of “N by M”, and is of the form shown in Equation (A6). 

   

   
















NXNX

XX

D

M

M






1

1 11

            (A6) 

Once the design matrix has been determined, initialize a weighting matrix (W) of size “N 

by N” with the identity matrix, and set   TNZZZZ ,),2(),1(  , where Z is the 
response variable of the form shown in Equation (A2).  Next, repeat the following matrix 
computations three times: 

  1T Tb D W D D W Y


                  (A7) 

R Z D b                 (A8) 

W = diagonal matrix with elements from BIWEIGHT(R1,R2,…,RN)       (A9) 

The values for b in Equation (A8) are determined from Equation (A7) and the 
corresponding explanatory variables.  In the first case (with an intercept), the estimated 
model parameters are given by Equations (A10) and (A11).    In the second case (without 
an intercept), the estimated model parameters are given by Equation (A12). 











M

M
M S

X
b

S

X
b

S

X
bb 

2

2
2

1

1
100̂         (A10) 

i

i
i S

b
̂  for i =1: M           (A11) 

ii b̂  for i =1: M           (A12) 

The BIWEIGHT function in Equation (A9) produces an N-dimensional output of weights 
from an N-dimensional input.  It is based on Tukey’s biweight function with c = 6 
(Reference 13).  Letting  nRRR ,,,BIWEIGHT 21   represent the biweight function and 

its input arguments, determine the weighting function as follows: 
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1. Compute the median absolute value (MAV) of the Ri’s determined from 
Equation (A8) 

2. Compute standardized values of Ri’s as shown by Equation (A13) 

3. 1 if 0  ii ZWEIGHT   for ni :1  

4.   1 if 1
22  iii ZUWEIGHT   for ni :1  

5. Return weights (W) to Equation (A9).  The updated diagonal elements of W 
are given by the values nWEIGHTWEIGHTWEIGHT ,,, 21  .  

 MAVc
ZU i

i 
           (A13)

 

2.1 Illustration of Linear Model Forms 

The default degradation model has the linearized form shown in Equation (A14).  This 
can be put into the form of Equation (A1) using Equation (A2) and the corresponding 
transformations shown in Equations (A15) through (A17), where the Xi’s are generic 
explanatory variables as defined by Equation (A3). 

    t
T

tT log
1

1;log 10           (A14) 

T
X

1
1              (A15) 

 tX log2              (A16) 

 2             (A17) 

The default error model has the linearized form given in Equation (A18), with the 
corresponding transformations shown in Equations (A19) through (A22). 

     22 2; ; 1iVar Y T t T t                (A18) 

  tTYVarZ i ;            (A19) 

  21 1;  tXX             (A20) 

2 2
0 2                 (A21) 

2
1               (A22) 
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3. POSSIBLE COMPLICATIONS WHEN ESTIMATING ERROR 
MODEL PARAMETERS 

Due to statistical fluctuations in the data, use of the estimation procedure might result in 

0ˆ 2  (i.e., 0ˆ
0  ) or 0ˆ 2   (i.e., 01̂  ).  Such negative estimates of variances can 

and should be regarded as nonsensical and the parameter estimates should be modified as 
discussed below. 

3.1 Case 1: 0ˆ 2   

In this case, the hypothesized measurement error was not detected.  First, it is 
recommended that an alternative non-negative estimate for 2  be specified (i.e.,  alt2̂ ).  
This estimate could be based on an independent assessment of the measurement error 
(Section 2.4.2, References 10-11).  If the measurement error variance is believed to be 
vanishingly small when compared to 2

 , then it might be prudent to consider   0ˆ 2 alt . 

Once the alternative estimate of 2̂ is available, 2ˆ  must be re-estimated.  This can be 

accomplished by first re-parameterizing the error model as shown in Equation (A23). 

       22
1ˆ; 2 ; 1iZ Var Y X t alt X t               (A23) 

For purposes of regression, each observation again consists of Z and X1, where X1 is the 
same as defined in the first column of Equation (A6) and Z is now the “within-group” 
variance of the response minus twice  alt2̂ .  In this case, however, use the robust linear 

regression procedure without an intercept. The resulting estimated slope ( 1̂ ) provides 

the value for  alt2ˆ . 

3.2 Case 2: 0ˆ 2   

In this case, the hypothesized random cell-specific proportional effect is not detectable.  
An alternative estimate for 2  can be determined with Equation (A24), where 
 

jnYYY ,,, 21   are the nj values of the response (e.g., relative resistance) for the jth of N 

groups defined by stress condition and time.  An alternative estimate for 2ˆ  would be to 

set it equal to zero,   alt2ˆ 0. 
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 
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          (A24) 
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Appendix B 

Methods for Estimating the Parameters of Nonlinear 
Degradation Models 
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Methods for Estimating the Parameters of Nonlinear 
Degradation Models 

1. INTRODUCTION 

This appendix summarizes the statistical methodology used for estimating the parameters 
associated with nonlinear degradation models.  A nonlinear model is generically 
represented by Equation (B1), where Z is a response variable, the Xi’s represent M 
explanatory variables, and the i’s are p model parameters which are to be estimated.  For 
estimating model parameters (i), it is assumed that there are N observations, each 
containing the observed value of the response variable, Z, and the associated values of the 
explanatory variables, Xi (e.g., inverse temperature).  Thus, the data consist of a set of 
observations, as shown in Equation (B2).  The model parameters are then estimated by 
using the robust nonlinear regression procedure described below. 

 pMXXXfZ  ,,,;,,, 2121                 (B1) 

         NiiXiXiXiZ M ,,2,1:,,,; 21             (B2) 

2. ROBUST NONLINEAR REGRESSION 

The model parameters are estimated by using an iterative robust nonlinear regression 
procedure based on Tukey’s biweight function (Reference 13).   The Levenberg-
Marquardt algorithm (Reference 8) is used with each iteration to estimate the parameter 
values.  The first iteration consists of ordinary nonlinear least-squares regression where 
the relative weights are identical.  Subsequent iterations use updated weights that are 
computed from the biweight function. 

For the first iteration, the Levenberg-Marquardt algorithm requires the user to supply 
initial guesses for the model parameters  p ,,, 21   and then searches to find 

parameter values that minimize the summation of the squared values of the residuals, as 
shown in Equation (B3).  Residuals for the nonlinear model are computed the same way 
as the linearizable model case and based on the difference between the predicted and 
actual response variable; this is defined in Equation (B4).  The predicted response 

variables, ˆ
iZ , are as shown in Equation (B5).  The resulting estimated parameter values 

are denoted by  p ˆ,,ˆ,ˆ
21  . 

 



N

i
ii ZZ

1

2ˆ                 (B3) 

 

iii ZZR  ˆ               (B4) 

 

      pMi iXiXiXfZ  ,,,;,,,ˆ
2121              (B5) 
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As with the linearizable model, a weighting matrix (W) can be generated using the 
biweight function as defined in Appendix A, where W is a diagonal matrix with elements 
from BIWEIGHT(R1,R2,…,RN).  The Levenberg-Marquardt algorithm is then re-applied 
(using the updated set of parameter estimates to begin the search) to find model 
parameter values that minimize the weighted summation of the squared values of the 
residuals, as shown in Equation (B6).  The process of computing residuals, followed by 
updating weights and parameter estimates continues for a total of two more iterations to 
determine final estimates for the model parameters. 
 

 



N

i
iii ZZW

1

2ˆ                (B6) 

 


